您的位置:首页 > 其它

hdu 3697(贪心+部分枚举)

2013-10-14 16:55 429 查看

Selecting courses

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 62768/32768 K (Java/Others)

Total Submission(s): 1300 Accepted Submission(s): 314



[align=left]Problem Description[/align]
A new Semester is coming and students are troubling for selecting courses. Students select their course on the web course system. There are n courses, the ith course is available during the time interval (Ai,Bi).
That means, if you want to select the ith course, you must select it after time Ai and before time Bi. Ai and Bi are all in minutes. A student can only try to select a course every 5 minutes, but he can start trying at any time, and try as many times as he
wants. For example, if you start trying to select courses at 5 minutes 21 seconds, then you can make other tries at 10 minutes 21 seconds, 15 minutes 21 seconds,20 minutes 21 seconds… and so on. A student can’t select more than one course at the same time.
It may happen that no course is available when a student is making a try to select a course

You are to find the maximum number of courses that a student can select.

[align=left]Input[/align]
There are no more than 100 test cases.

The first line of each test case contains an integer N. N is the number of courses (0<N<=300)

Then N lines follows. Each line contains two integers Ai and Bi (0<=Ai<Bi<=1000), meaning that the ith course is available during the time interval (Ai,Bi).

The input ends by N = 0.

[align=left]Output[/align]
For each test case output a line containing an integer indicating the maximum number of courses that a student can select.

[align=left]Sample Input[/align]

2
1 10
4 5
0


[align=left]Sample Output[/align]

2


#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn = 310;
struct lesson{
int s;
int e;
}l[maxn];
int N , ans , L , R;

bool cmp(lesson l1 , lesson l2){
return l1.e < l2.e;
}

void readcase(){
L = 10000;
R = 0;
ans = 0;
for(int i = 0;i < N;i++){
//cin >> l[i].s >> l[i].e;
scanf("%d%d" , &l[i].s , &l[i].e);
l[i].e--;
L = min(L , l[i].s);
R = max(R , l[i].e);
}
}

void computing(){
sort(l , l+N , cmp);
//cout << L << " " << R << endl;
for(int j = 0;j < 5;j++){
int i = L+j;
int vis[310] = {0};
int temp = 0;
while(i <= R){
for(int k = 0;k < N;k++){
if(vis[k] == 0 && l[k].s <= i && l[k].e >= i){
vis[k] = 1;
temp++;
break;
}
}
i += 5;
}
ans = max(ans , temp);
//cout << ans <<" "<<L<< endl;
if(ans >= N){	break;}
}
//cout << ans << endl;
printf("%d\n" , ans);
}

int main(){
while(cin >> N &&N){
readcase();
computing();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: