您的位置:首页 > 其它

数学->hdu 2973

2013-10-12 18:37 489 查看
YAPTCHA
Time Limit:5000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status Practice HDU
2973

Description

The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-Public-Turing-Test-to-Tell-Computers-and-Humans-Apart
on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.

However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

The task that is presented to anyone visiting the start page of the math department is as follows: given a natural n, compute



where [x] denotes the largest integer not greater than x.

Input

The first line contains the number of queries t (t <= 10^6). Each query consist of one natural number n (1 <= n <= 10^6).

Output

For each n given in the input output the value of Sn.

Sample Input

13
1
2
3
4
5
6
7
8
9
10
100
1000
10000


Sample Output

0
1
1
2
2
2
2
3
3
4
28
207
1609


#include <iostream>
#include <string.h>
#include <cmath>

using namespace std;

#define MAXN 3000000 + 10

bool is_prime[MAXN];
int n;
int s[MAXN];

void prime()
{
memset(is_prime, false, sizeof(is_prime));

is_prime[0] = is_prime[1] = true;

for (int i = 2; i < 1800; i++)
{
if (!is_prime[i])
{
int temp = i * 2;

while (temp <= MAXN)
{
is_prime[temp] = true;
temp += i;
}
}
}
}

void init()
{
s[0] = 0;
for(int i = 1; i <= 1000000; i++)
{
if(!is_prime[i * 3 + 7])
{
s[i] = s[i - 1] + 1;
}
else
{
s[i] = s[i - 1];
}
}
}

void input()
{
int t;

prime();
init();

cin >> t;
while (t--)
{
cin >> n;

cout << s
<< endl;
}
}

int main()
{
std::ios::sync_with_stdio(false);
input();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: