您的位置:首页 > 其它

最短路->hdu 3631 Shortest Path

2013-10-12 18:16 357 查看
Shortest Path
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status Practice HDU
3631

Description

When YY was a boy and LMY was a girl, they trained for NOI (National Olympiad in Informatics) in GD team. One day, GD team’s coach, Prof. GUO asked them to solve the following shortest-path problem.

There is a weighted directed multigraph G. And there are following two operations for the weighted directed multigraph:

(1) Mark a vertex in the graph.

(2) Find the shortest-path between two vertices only through marked vertices.

For it was the first time that LMY faced such a problem, she was very nervous. At this moment, YY decided to help LMY to analyze the shortest-path problem. With the help of YY, LMY solved the problem at once, admiring YY very much. Since then, when LMY meets
problems, she always calls YY to analyze the problems for her. Of course, YY is very glad to help LMY. Finally, it is known to us all, YY and LMY become programming lovers.

Could you also solve the shortest-path problem?

Input

The input consists of multiple test cases. For each test case, the first line contains three integers N, M and Q, where N is the number of vertices in the given graph, N≤300; M is the number of arcs, M≤100000; and Q is the number
of operations, Q ≤100000. All vertices are number as 0, 1, 2, … , N - 1, respectively. Initially all vertices are unmarked. Each of the next M lines describes an arc by three integers (x, y, c): initial vertex (x), terminal vertex (y), and the weight of the
arc (c). (c > 0) Then each of the next Q lines describes an operation, where operation “0 x” represents that vertex x is marked, and operation “1 x y” finds the length of shortest-path between x and y only through marked vertices. There is a blank line between
two consecutive test cases.

End of input is indicated by a line containing N = M = Q = 0.

Output

Start each test case with "Case #:" on a single line, where # is the case number starting from 1.

For operation “0 x”, if vertex x has been marked, output “ERROR! At point x”.

For operation “1 x y”, if vertex x or vertex y isn’t marked, output “ERROR! At path x to y”; if y isn’t reachable from x through marked vertices, output “No such path”; otherwise output the length of the shortest-path. The format is showed as sample output.

There is a blank line between two consecutive test cases.

Sample Input

5 10 10
1 2 6335
0 4 5725
3 3 6963
4 0 8146
1 2 9962
1 0 1943
2 1 2392
4 2 154
2 2 7422
1 3 9896
0 1
0 3
0 2
0 4
0 4
0 1
1 3 3
1 1 1
0 3
0 4
0 0 0


Sample Output

Case 1:
ERROR! At point 4
ERROR! At point 1
0
0
ERROR! At point 3
ERROR! At point 4
#include <iostream>
#include <cmath>
#include <cstdio>
#include <string.h>

using namespace std;

#define MAXN 300 + 10
#define INF 0x3f3f3f3f3f3f3f3fLL

int n, m, q;
long long c[MAXN][MAXN];
bool vis[MAXN];

void input()
{
int u, v, k = 0;
long long w;

while (scanf("%d %d %d", &n, &m, &q) != EOF)
{
if (!n && !m && !q)
{
break;
}

memset(vis, false, sizeof(vis));

for (int i = 0; i < n; i++)
{
for (int j = 0; j < n; j++)
{
if (i == j)
{
c[i][j] = 0;
}
else
{
c[i][j] = INF;
}
}
}

for (int i = 0; i < m; i++)
{
scanf("%d %d %I64d", &u, &v, &w);
if (c[u][v] > w)
{
c[u][v] = w;
}
}

int op, mark;

if (k != 0)
{
printf("\n");
}
cout << "Case " << ++k << ':' << endl;
for (int i = 0; i < q; i++)
{
scanf("%d", &op);

if (!op)
{
scanf("%d", &mark);
if (vis[mark])
{
printf("ERROR! At point %d\n", mark);
}
else
{
vis[mark] = true;

for (int j = 0; j < n; j++)
{
for (int k = 0; k < n; k++)
{
c[j][k] = min(c[j][k], c[j][mark] + c[mark][k]);
}
}
}
}
else if (op == 1)
{
scanf("%d %d", &u, &v);

if (!vis[u] || !vis[v])
{
printf("ERROR! At path %d to %d\n", u, v);
}
else if (c[u][v] == INF)
{
printf("No such path\n");
}
else
{
printf("%I64d\n", c[u][v]);
}
}
}
}
}

int main()
{
input();
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: