您的位置:首页 > 其它

HDU - 1224 Free DIY Tour DP

2013-10-11 22:28 351 查看


Free DIY Tour


Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)


Total Submission(s) : 4 Accepted Submission(s) : 2


Problem Description

Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It's a good chance to relax themselves.
To most of them, it's the first time to go abroad so they decide to make a collective tour.

The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company's statistic, each city has its own interesting point. For instance, Paris has its
interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In
order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number.

Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both 1 andN+1), and its interesting point is always 0.

Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?

Input

The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.

Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.

Then N integers follows, representing the interesting point list of the cities.

And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.

Output

For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit.

Output a blank line between two cases.

Sample Input

2
3
0 70 90
4
1 2
1 3
2 4
3 4
3
0 90 70
4
1 2
1 3
2 4
3 4


Sample Output

CASE 1#
points : 90
circuit : 1->3->1

CASE 2#
points : 90
circuit : 1->2->1


Source

杭州电子科技大学第三届程序设计大赛

题意:有N个城市,每个城市都有一个魅力值,从编号1的城市开始飞,每次只能从编号小的飞到编号大的城市,最后飞到起点城市(此时起点编号为N+1)。

水题 不懂哪里错了 wa了20几次 QAQ

#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
const int maxn = 105;
int n,m;
int p[maxn],dp[maxn],path[maxn];
vector<int>map[maxn];

void getDP()
{
memset(dp,0,sizeof(dp));
dp[1] = p[1];
path[1] = 0;
p[n+1] = 0;
for( int i = 1; i <= n; i ++ )
{
for( int j = 0; j < map[i].size(); j ++ )
{
int v = map[i][j];
if( dp[v] < dp[i] + p[v] )
{
dp[v] = dp[i] + p[v];
path[v] = i;
}
}
}
}
void output(int x)
{
if( path[x] != 0 )
output( path[x] );
printf("%d->",x);
}

int main()
{
//freopen("data.in","r",stdin);
int t,a,b;
int cas = 1;
scanf("%d",&t);
while( t-- )
{
scanf("%d",&n);
for( int i = 1; i <= n; i ++ )
{
map[i].clear();
scanf("%d",&p[i]);
}
scanf("%d",&m);
for( int i = 1; i <= m; i ++ )
{
scanf("%d%d",&a,&b);
map[a].push_back(b);
}
getDP();
printf("CASE %d#\npoints : %d\ncircuit : ",cas++,dp[n+1]);
output( path[n+1] );
printf("1\n");
if( t )
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: