您的位置:首页 > 其它

ACM STEP 1.2.3 Nasty Hacks

2013-10-11 20:01 411 查看

Nasty Hacks

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2161 Accepted Submission(s): 1359
Problem Description

You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use

to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with
and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.

Input

The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do
advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -106 ≤ r, e ≤ 106 and 0 ≤ c ≤ 106.

Output

Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference.

Sample Input

3
0 100 70
100 130 30
-100 -70 40


Sample Output

advertise
does not matter
do not advertise


Source

Nordic 2006

Recommend

zty

#include <iostream>
using namespace std;
int main()
{
double r,e,c,m,s;
int i;
void display(int t);
cin >>i;
while(i--)
{
cin >>r;
cin >>e;
cin >>c;
m=e-c;
if(m>r) s=1;
else if(m==r) s=2;
else s=3;
display(s);
}
return 0;
}

void display(int t)
{
switch (t) {
case 1:
cout <<"advertise"<<endl;
break;
case 2:
cout <<"does not matter"<<endl;
break;
case 3:
cout <<"do not advertise"<<endl;
break;
default:
break;
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: