您的位置:首页 > Web前端

HDU 4009 Transfer water 最小树形图(简单题)

2013-10-11 16:02 549 查看
点击打开链接

Transfer water

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)

Total Submission(s): 3096    Accepted Submission(s): 1154

[align=left]Problem Description[/align]
XiaoA lives in a village. Last year flood rained the village. So they decide to move the whole village to the mountain nearby this year. There is no spring in the mountain, so each household could only dig a well or build a water
line from other household. If the household decide to dig a well, the money for the well is the height of their house multiplies X dollar per meter. If the household decide to build a water line from other household, and if the height of which supply water
is not lower than the one which get water, the money of one water line is the Manhattan distance of the two households multiplies Y dollar per meter. Or if the height of which supply water is lower than the one which get water, a water pump is needed except
the water line. Z dollar should be paid for one water pump. In addition,therelation of the households must be considered. Some households may do not allow some other households build a water line from there house. Now given the 3‐dimensional position (a, b,
c) of every household the c of which means height, can you calculate the minimal money the whole village need so that every household has water, or tell the leader if it can’t be done.
 

[align=left]Input[/align]
Multiple cases.

First line of each case contains 4 integers n (1<=n<=1000), the number of the households, X (1<=X<=1000), Y (1<=Y<=1000), Z (1<=Z<=1000).

Each of the next n lines contains 3 integers a, b, c means the position of the i‐th households, none of them will exceeded 1000.

Then next n lines describe the relation between the households. The n+i+1‐th line describes the relation of the i‐th household. The line will begin with an integer k, and the next k integers are the household numbers that can build a water line from the i‐th
household.

If n=X=Y=Z=0, the input ends, and no output for that.

 

[align=left]Output[/align]
One integer in one line for each case, the minimal money the whole village need so that every household has water. If the plan does not exist, print “poor XiaoA” in one line.

 

[align=left]Sample Input[/align]

2 10 20 30
1 3 2
2 4 1
1 2
2 1 2
0 0 0 0

 

[align=left]Sample Output[/align]

30

HintIn 3‐dimensional space Manhattan distance of point A (x1, y1, z1) and B(x2, y2, z2) is |x2‐x1|+|y2‐y1|+|z2‐z1|.

 

[align=left]Source[/align]
The 36th ACM/ICPC
Asia Regional Dalian Site —— Online Contest
 

[align=left]Recommend[/align]
lcy

题意是说在一个高山上有很多房子需要建一个井和水流通道,每个房子都可以建井,井的费用是此房子高度*X,某些房子之间可以建水流通道,如果水流从房子a流向房子b,而且a的高度高于b,那么费用就只需他们之间的距离*Y,否则还要加上买水泵的钱Z。让你求最少花费使得所有房子都能供上水。
最小树形图入门题,建图:
将能够连接的房子之间建立通道,费用为两房子之间建立通道的费用。
设水井为一个超级源,然后这个超级源连接每个房子,费用为每个房子建立水井的花费。
最后直接套用朱刘算法模板即可。

#include<stdio.h>
#include<string.h>
#include<math.h>
#define M 1007
#define inf 0x3f3f3f
using namespace std;
int pre[M],vis[M],id[M];
int in[M];
int n,x,y,z;

struct Node
{
int u,v;
int cost;
}E[M*M+5];

struct point
{
int x,y,z;
}p[M];

int dis(point a,point b)
{
int ans=(fabs(a.x-b.x)+fabs(a.y-b.y)+fabs(a.z-b.z))*y;
if(a.z<b.z)
ans+=z;
return ans;
}

int direct_mst(int root,int nv,int ne)
{
int ret=0;
while(true)
{
//找最小入边
for(int i=0;i<nv;i++)
in[i]=inf;
for(int i=0;i<ne;i++)
{
int u=E[i].u;
int v=E[i].v;
if(E[i].cost<in[v]&&u!=v)
{
pre[v]=u;
in[v]=E[i].cost;
}
}
for(int i=0;i<nv;i++)
{
if(i==root)continue;
if(in[i]==inf)return -1;
}
//找环
int cntnode=0;
memset(id,-1,sizeof(id));
memset(vis,-1,sizeof(vis));
in[root]=0;
for(int i=0;i<nv;i++)//标记每个环
{
ret+=in[i];
int v=i;
while(vis[v]!=i&&id[v]==-1&&v!=root)
{
vis[v]=i;
v=pre[v];
}
if(v!=root&&id[v]==-1)
{
for(int u=pre[v];u!=v;u=pre[u])
{
id[u]=cntnode;
}
id[v]=cntnode++;
}
}
if(cntnode==0)break;//无环
for(int i=0;i<nv;i++)
if(id[i]==-1)
id[i]=cntnode++;
//缩点,重新标记
for(int i=0;i<ne;i++)
{
int v=E[i].v;
E[i].u=id[E[i].u];
E[i].v=id[E[i].v];
if(E[i].u!=E[i].v)
{
E[i].cost-=in[v];
}
}
nv=cntnode;
root=id[root];
}
return ret;
}

int main()
{
while(scanf("%d%d%d%d",&n,&x,&y,&z),n|x|y|z)
{
int num=0,flag,to;
for(int i=1;i<=n;i++)
scanf("%d%d%d",&p[i].x,&p[i].y,&p[i].z);
for(int i=1;i<=n;i++)
{
scanf("%d",&flag);
while(flag--)
{
scanf("%d",&to);
E[num].u=i;
E[num].v=to;
if(to!=i)
E[num].cost=dis(p[E[num].u],p[E[num].v]);
else
E[num].cost=inf;
num++;
}
}
for(int i=1;i<=n;i++)
{
E[num].u=0;
E[num].v=i;
E[num].cost=p[i].z*x;
num++;
}
int ans=direct_mst(0,n+1,num);
if(ans==-1)
printf("poor XiaoA\n");
else
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: