您的位置:首页 > 其它

题目1001:A+B for Matrices

2013-10-08 22:35 302 查看
题目描述:
This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:
The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines
follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

The input is terminated by a zero M and that case must NOT be processed.

输出:
For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0


样例输出:
1
5


来源: 2011年浙江大学计算机及软件工程研究生机试真题

解析: 题目意思为求矩阵行全为0或列全为0的行数和列数。
code:
#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
   int a[100][100]={0},b[100][100]={0},c[100][100]={0},n,m,i,j,k,l;
   while(cin>>n>>m && n!=0)
   {    
      // memset(a,0,sizeof(a));
      //  memset(b,0,sizeof(b));
    //     memset(c,0,sizeof(c));
        for(i=0;i<n;i++)
           for(j=0;j<m;j++)
              cin>>a[i][j];
               for(i=0;i<n;i++)
           for(j=0;j<m;j++)
              cin>>b[i][j];
               for(i=0;i<n;i++)
           for(j=0;j<m;j++)
              c[i][j]=a[i][j]+b[i][j];
          
              l=1;k=0;
              for(i=0;i<n;i++)
              { 
                    l=1;
                 for(j=0;j<m;j++) 
                 {
                      if(c[i][j]!=0)
                        { l=0; break;}                                    
                 }
                  if(l==1)
                    k++;                               
              }
              l=1;
           for(j=0;j<m;j++)
              {
                   l=1;
              for(i=0;i<n;i++)
                 {
                      if(c[i][j]!=0)
                        { l=0; break;}                        
                 }
                  if(l==1)
                    k++;   
              }  
           cout<<k<<endl;
        }
       // system("pause");
        return 0;
    }
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: