您的位置:首页 > 产品设计 > UI/UE

HDU--1005 -- Number Sequence [数论]

2013-10-07 10:00 453 查看


Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 85857    Accepted Submission(s): 20359

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

Output

For each test case, print the value of f(n) on a single line.

 

Sample Input

1 1 3
1 2 10
0 0 0

 

Sample Output

2
5

Code:

#include<stdio.h>
int ans[10000];

int main()
{
int a,b,n;
while(scanf("%d%d%d",&a,&b,&n),a||b||n)
{
int i;
ans[1] = ans[2] = 1;
for(i=3;i<10000;i++)
{
ans[i] = (a*ans[i-1] + b*ans[i-2])%7;
if(ans[i]==1 && ans[i-1]==1) break;//重新回到原点时即为一个周期
}
n = n%(i-2);//i-2为周期
if(n==0) n = i-2;
printf("%d\n",ans
);
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: