您的位置:首页 > 其它

最小生成树(prim)--poj2377

2013-10-01 20:09 246 查看
Language:
Default

Bad Cowtractors

Time Limit: 1000MS

Memory Limit: 65536K

Total Submissions: 9438

Accepted: 4037

Description

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns.
Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie.

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that
it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of
connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input
5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17


Sample Output
42

思路:求费用最高,建图的时候可以把费用去相反数,然后求最小生成树。
#include<iostream>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<cmath>
#include<climits>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
typedef long long LL;
using namespace std;
const int INF=10000000;
int N,M;
int col[1005][1005];
int dis[1005];
bool vis[1005];
void prim()
{
    int ans=0;
    int biao;
    for(int i=1; i<=N; i++)
    {
        if(col[1][i]==0)
            dis[i]=INF;
        else
        dis[i]=col[1][i];
        vis[i]=false;
    }

    dis[1]=0;
    vis[1]=true;
    for(int i=2; i<=N; i++)
    {
        int min1=INF;
        for(int j=2; j<=N; j++)
        {
            if((!vis[j])&&dis[j]<min1)
            {
                min1=dis[j];
                biao=j;
            }
        }
        ans+=min1;
        vis[biao]=true;
        for(int j=1; j<=N; j++)
            if((!vis[j])&&(col[j][biao]!=0)&&dis[j]>col[j][biao])
                dis[j]=col[j][biao];
    }

    for(int i=1; i<=N; i++)
        if(dis[i]>=INF)
        {
            cout<<-1<<endl;
            return;
        }
    cout<<-ans<<endl;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int u,v,x;
    while(cin>>N>>M)
    {
        memset(col,0,sizeof(col));
        memset(vis,false,sizeof(vis));
        for(int i=1; i<=M; i++)
        {
            cin>>u>>v>>x;
            col[u][v]=min(col[u][v],-x);
            col[v][u]=col[u][v];
        }
        prim();
    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: