您的位置:首页 > 其它

Paths on a Grid POJ 1942 组合数学

2013-09-25 11:03 651 查看
Paths on a Grid

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 19898Accepted: 4827
Description
Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b)2=a2+2ab+b2).
So you decide to waste your time with drawing modern art instead. 

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner,
taking care that it stays on the lines and moves only to the right or up. The result is shown on the left: 



Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?
Input
The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding
grid is one more in each dimension. Input is terminated by n=m=0.
Output
For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step
of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.
Sample Input
5 4
1 1
0 0

Sample Output
126
2

Source
Ulm Local 2002
 
 
 
 
这道题目是说在n*m 的方格中找到一条路,使从最左角到最右角,也就是我们肯定要往左走,对我来说选择就是往左
                                       

或者往右走,一共要走m+n步,我们挑出m步往右走,C(m+n,n)就行了,但我本来是想要用打表的,用数组来进行模
 
拟的,但是这两个数是unsigned位,两个数相加的话就这个就会是unsigned*2大小的,数组可能开不了这么大的,而
 
时间一定会超的,所以我们要用一个式子来求C(m+n,n);C(M,N)=M!/(M-N)!*N!,但是我们再挑N的时候要选那个比
 
小的N,这样算起来会更省时间,但是求其阶乘也是不现实的,所以约分是最好的办法,C(7,2)=7!/(5!*2!),我们
 
在算的时候7!可以用5!来约分掉,这样就只剩下7*6,于2!的商就是了!!!!
 
 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
int i,j,k;
unsigned int n;
unsigned int m;
unsigned int sum;
while(cin>>n>>m)
{
if((n==0)&&(m==0))
break;
sum=n+m;
if(n<m)
swap(n,m);
//cout<<n<<m;
double s=1;
while(m>0)
{
s=s*(double)sum/(double)m;
sum--;
m--;
}
printf("%.0f\n",s);
}
return 0;
}


 
                                        

 
 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: