您的位置:首页 > 其它

UVa 575 / ZOJ 1712 / Mid-Central USA 1997 Skew Binary (water ver.&斜二进制)

2013-09-21 09:55 393 查看


575 - Skew Binary

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=516

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1712

When a number is expressed in decimal, the k-th digit represents a multiple of 10k. (Digits are numbered from right to left, where the least significant digit is number 0.) For example,



When a number is expressed in binary, the k-th digit represents a multiple of 2k. For example,



In skew binary, the k-th digit represents a multiple of 2k+1 - 1. The only possible digits are 0 and 1, except that the least-significant nonzero digit can be a 2. For example,



The first 10 numbers in skew binary are 0, 1, 2, 10, 11, 12, 20, 100, 101, and 102. (Skew binary is useful in some applications because it is possible to add 1 with at most one carry. However, this has nothing to do
with the current problem.)

Input

The input file contains one or more lines, each of which contains an integer n. If n =
0 it signals the end of the input, and otherwise n is a nonnegative integer in skew binary.

Output

For each number, output the decimal equivalent. The decimal value of n will be at most 231 -
1 = 2147483647.

Sample Input

10120
200000000000000000000000000000
10
1000000000000000000000000000000
11
100
11111000001110000101101102000
0


Sample Output

44
2147483646
3
2147483647
4
7
1041110737


直接模拟,注意些小技巧。

完整代码:

/*UVa: 0.015s*/
/*POJ: 16ms,164KB*/
/*ZOJ: 0ms,180KB*/

#include<cstdio>
#include<cstring>

char skew[32];

int main(void)
{
	while (scanf("%s", skew), strcmp(skew, "0"))
	{
		int len = strlen(skew), ans = 0;
		for (int i = 0; i < len; i++)
			ans += (skew[i] & 15) * ((1 << len - i) - 1);
		printf("%d\n", ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: