您的位置:首页 > 其它

成都赛区1010 A Bit Fun

2013-09-19 19:04 204 查看

A Bit Fun

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 839    Accepted Submission(s): 496


[align=left]Problem Description[/align]
There are n numbers in a array, as a0, a1 ... , an-1, and another number m. We define a function f(i, j) = ai|ai+1|ai+2| ... | aj . Where "|" is the bit-OR
operation. (i <= j)

The problem is really simple: please count the number of different pairs of (i, j) where f(i, j) < m.
 

[align=left]Input[/align]
The first line has a number T (T <= 50) , indicating the number of test cases.

For each test case, first line contains two numbers n and m.(1 <= n <= 100000, 1 <= m <= 230) Then n numbers come in the second line which is the array a, where 1 <= ai <= 230.
 

[align=left]Output[/align]
For every case, you should output "Case #t: " at first, without quotes. The
t is the case number starting from 1.

Then follows the answer.
 

[align=left]Sample Input[/align]

2
3 6
1 3 5
2 4
5 4

 

[align=left]Sample Output[/align]

Case #1: 4
Case #2: 0

 

[align=left]Source[/align]
2013 ACM/ICPC Asia Regional Chengdu Online

 

[align=left]Recommend[/align]

这道题 就是暴力搜索 +一个简单的剪枝

#include<iostream>
using namespace std;
using namespace std;
int a[100010];
int t,n,m,count,ii;

int main()
{
ii=0;
cin>>t;
while(t--)
{
ii++;
count=0;
cin>>n>>m;
for(int i=0;i<n;i++)
{
cin>>a[i];
if(a[i]<m) count++;
}
for(int i=0;i<n;i++)
{
int sum=a[i];
for(int j=i+1;j<n;j++)
{
sum=sum|a[j];
if(sum<m ) count++;
else  break;
}

}
cout<<"Case #"<<ii<<": ";
cout<<count<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: