您的位置:首页 > 其它

HDU 4716 A Computer Graphics Problem

2013-09-16 19:39 375 查看

A Computer Graphics Problem

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 336 Accepted Submission(s): 277


Problem Description

In this problem we talk about the study of Computer Graphics. Of course, this is very, very hard.

We have designed a new mobile phone, your task is to write a interface to display battery powers.

Here we use '.' as empty grids.

When the battery is empty, the interface will look like this:

*------------*
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
*------------*


When the battery is 60% full, the interface will look like this:

*------------*
|............|
|............|
|............|
|............|
|------------|
|------------|
|------------|
|------------|
|------------|
|------------|
*------------*


Each line there are 14 characters.

Given the battery power the mobile phone left, say x%, your task is to output the corresponding interface. Here x will always be a multiple of 10, and never exceeds 100.

Input

The first line has a number T (T < 10) , indicating the number of test cases.

For each test case there is a single line with a number x. (0 < x < 100, x is a multiple of 10)

Output

For test case X, output "Case #X:" at the first line. Then output the corresponding interface.

See sample output for more details.

Sample Input

2
0
60

Sample Output

Case #1:
*------------* |............| |............| |............| |............| |............| |............| |............| |............| |............| |............| *------------*
Case #2:
*------------* |............| |............| |............| |............| |------------| |------------| |------------| |------------| |------------| |------------| *------------*

Source

2013 ACM/ICPC Asia Regional Online —— Warmup2

import java.io.*;
import java.util.*;
public class Main {

public static void main(String[] args) throws IOException{
new Main().work();
}
void work() throws IOException{
BufferedReader bu=new BufferedReader(new InputStreamReader(System.in));
//PrintWriter pw=new PrintWriter(new OutputStreamWriter(System.out),true);
int t=Integer.parseInt(bu.readLine());
for(int j=1;j<=t;j++){
System.out.println("Case #"+j+":");
int x=Integer.parseInt(bu.readLine());
first();
int m=x/10;
for(int i=0;i<10-m;i++){
second();
}
for(int i=0;i<m;i++){
fir();
}
first();
}
}
void fir(){
System.out.print("|");
for(int i=0;i<12;i++){
System.out.print("-");
}
System.out.print("|");
System.out.println();
}
void second(){
System.out.print("|");
for(int i=0;i<12;i++){
System.out.print(".");
}
System.out.print("|");
System.out.println();
}
void first(){
System.out.print("*");
for(int i=0;i<12;i++){
System.out.print("-");
}
System.out.print("*");
System.out.println();
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: