您的位置:首页 > 其它

poj 2230 Watchcow(有向图的欧拉回路)

2013-09-16 15:35 441 查看
Watchcow

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 5490Accepted: 2326Special Judge
Description
Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn
when she's done.

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see.
But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice.

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.
Input
* Line 1: Two integers, N and M.

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.
Output
* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.
Sample Input
4 5
1 2
1 4
2 3
2 4
3 4

Sample Output
1
2
3
4
2
1
4
3
2
4
1

Hint
OUTPUT DETAILS:

Bessie starts at 1 (barn), goes to 2, then 3, etc...

题意:给出一个无向图,一笔画,求经过每条边恰好两次,且经过每条边的第一次和第二次方向相反,输出经过的点的路径。
思路:将无向边看成有向边,然后求有向图的欧拉回路,dfs输出路径。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <map>
#include <cstdlib>
#define L(rt) (rt<<1)
#define R(rt) (rt<<1|1)
#define ll long long
#define eps 1e-6
using namespace std;

const int maxn=10005;
struct node
{
int v,next;
}edge[50005*2];
int head[maxn];
bool vis[50005*2];
int n,m,num;
void init()
{
memset(head,-1,sizeof(head));
memset(vis,false,sizeof(vis));
num=0;
}
void add(int u,int v)
{
edge[num].v=v;
edge[num].next=head[u];
head[u]=num++;
}
void dfs(int u)
{
for(int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].v;
if(!vis[i])
{

vis[i]=true;
dfs(v);
}
}
printf("%d\n",u);
}
int main()
{
int a,b;
while(~scanf("%d%d",&n,&m))
{
init();
while(m--)
{
scanf("%d%d",&a,&b);
add(a,b);
add(b,a);
}
dfs(1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: