您的位置:首页 > 其它

hdu 4737 A Bit Fun 暴力

2013-09-14 18:01 429 查看


A Bit Fun

Time Limit: 5000/2500 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 76 Accepted Submission(s): 41



Problem Description

There are n numbers in a array, as a0, a1 ... , an-1, and another number m. We define a function f(i, j) = ai|ai+1|ai+2| ... | aj . Where "|" is the bit-OR operation. (i <= j)

The problem is really simple: please count the number of different pairs of (i, j) where f(i, j) < m.



Input

The first line has a number T (T <= 50) , indicating the number of test cases.

For each test case, first line contains two numbers n and m.(1 <= n <= 100000, 1 <= m <= 230) Then n numbers come in the second line which is the array a, where 1 <= ai <= 230.



Output

For every case, you should output "Case #t: " at first, without quotes. The t is the case number starting from 1.

Then follows the answer.



Sample Input

2
3 6
1 3 5
2 4
5 4




Sample Output

Case #1: 4
Case #2: 0




Source

2013 ACM/ICPC Asia Regional Chengdu Online



Recommend

liuyiding

题意:n个数的序列,求出若干个连续的数按位或后结果小于m的个数。

分析:按位或运算出后的结果只会增加不会减少

#include <iostream>
#include <cstdio>
using namespace std;
int num[100005];
int main()
{
    int ncase,nc=0,i,j,ans,t,n,m;
    scanf("%d",&ncase);
    while(ncase--)
    {
        ans=0;
        nc++;
        scanf("%d%d",&n,&m);
        for(i=0; i<n; i++)
            scanf("%d",&num[i]);
        for(i=0; i<n; i++)
        {
            t=num[i];
            for(j=i; j<n; j++)
            {
                t=t|num[j];
                if(t<m) ans++;
                else break;
            }
        }
        printf("Case #%d: %d\n",nc,ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: