您的位置:首页 > 其它

As Easy As A+B hdu 1040

2013-09-14 10:49 381 查看

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 30198    Accepted Submission(s): 12941


[align=left]Problem Description[/align]
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.

Give you some integers, your task is to sort these number ascending (升序).

You should know how easy the problem is now!

Good luck!

 

[align=left]Input[/align]
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted)
and then N integers follow in the same line. 

It is guarantied that all integers are in the range of 32-int.

 

[align=left]Output[/align]
For each case, print the sorting result, and one line one case.

 

[align=left]Sample Input[/align]

2
3 2 1 3
9 1 4 7 2 5 8 3 6 9

 

[align=left]Sample Output[/align]

1 2 3
1 2 3 4 5 6 7 8 9

 

[align=left]Author[/align]
lcy
 
 
 
太水了,不想说了
 
 

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int main()
{
int a[1030];
int i,j,k,n,t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
sort(a,a+n);
for(i=0;i<n-1;i++)
printf("%d ",a[i]);
printf("%d\n",a[n-1]);

}

}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: