您的位置:首页 > 其它

UVa 490 Rotating Sentences (water ver.)

2013-09-13 20:56 417 查看


490 - Rotating Sentences

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=94&page=show_problem&problem=431

In ``Rotating Sentences,'' you are asked to rotate a series of input sentences 90 degrees clockwise. So instead of displaying the input sentences from left to right and top to bottom, your program will display them
from top to bottom and right to left.

Input and Output

As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100 characters long. Legal characters include: newline, space, any punctuation characters, digits, and lower case or upper case
English letters. (NOTE: Tabs are not legal characters.)

The output of the program should have the last sentence printed out vertically in the leftmost column; the first sentence of the input would subsequently end up at the rightmost column.

Sample Input

Rene Decartes once said,
"I think, therefore I am."


Sample Output

"R
Ie
 n
te
h 
iD
ne
kc
,a
 r
tt
he
es
r
eo
fn
oc
re
e
 s
Ia
 i
ad
m,
.
"


注意短句子后面要输出空格。

完整代码:

/*0.012s*/

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

char in[110][110];
int len[110];

int main(void)
{
	int i, j, idx = 0, Max = 0;
	while (gets(in[idx]))
	{
		len[idx] = strlen(in[idx]);
		Max = max(Max, len[idx++]);
	}
	for (j = 0; j < Max; j++)
	{
		for (i = idx - 1; i >= 0; i--)
			putchar(j < len[i] ? in[i][j] : ' ');
		putchar('\n');
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: