您的位置:首页 > 其它

HDU_1018 big number

2013-09-13 20:55 281 查看

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 21581    Accepted Submission(s): 9713


[align=left]Problem Description[/align]
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of
digits in the factorial of the number.

 

[align=left]Input[/align]
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

 

[align=left]Output[/align]
The output contains the number of digits in the factorial of the integers appearing in the input.

 

[align=left]Sample Input[/align]

2
10
20

 

[align=left]Sample Output[/align]

7
19

 

[align=left]Source[/align]
Asia 2002, Dhaka (Bengal)

 

[align=left]Recommend[/align]
JGShining
 

#include<stdio.h>
#include<math.h>
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
int a,i;
double sum=0;
scanf("%d",&a);
for(i=1;i<=a;i++)
{
sum+=log10(double(i));
}
printf("%d\n",int(sum)+1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  math.h