您的位置:首页 > 其它

简单dfs--poj2386

2013-09-12 14:57 246 查看
Language:
Default

Lake Counting

Time Limit: 1000MS

Memory Limit: 65536K

Total Submissions: 16414

Accepted: 8323

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure
out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.


Sample Output
3

#include<iostream>
#include<cstdio>
using namespace std;
char map[110][110];
int N,M;
int dx[]={-1,-1,-1,0,0,1,1,1};
int dy[]={-1,0,1,-1,1,-1,0,1};
void dfs(int x,int y)
{
    map[x][y]='.';
    for(int i=0;i<8;i++)
    {
        int tx=x+dx[i];
        int ty=y+dy[i];
        if(tx>=0&&tx<N&&ty>=0&&ty<M&&(map[tx][ty]=='W'))
            dfs(tx,ty);
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    int ans;
    while(cin>>N>>M)
    {
        for(int i=0;i<N;i++)
            for(int j=0;j<M;j++)
                cin>>map[i][j];
        ans=0;
        for(int i=0;i<N;i++)
            for(int j=0;j<M;j++)
            if(map[i][j]=='W')
            {
                dfs(i,j);
                ans++;
            }
        cout<<ans<<endl;
    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: