您的位置:首页 > 其它

HDU 4716 A Computer Graphics Problem (水题)

2013-09-11 17:34 537 查看

A Computer Graphics Problem

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 43 Accepted Submission(s): 40


[align=left]Problem Description[/align]
In this problem we talk about the study of Computer Graphics. Of course, this is very, very hard.
We have designed a new mobile phone, your task is to write a interface to display battery powers.
Here we use '.' as empty grids.
When the battery is empty, the interface will look like this:

*------------*
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
*------------*


When the battery is 60% full, the interface will look like this:

*------------*
|............|
|............|
|............|
|............|
|------------|
|------------|
|------------|
|------------|
|------------|
|------------|
*------------*


Each line there are 14 characters.
Given the battery power the mobile phone left, say x%, your task is to output the corresponding interface. Here x will always be a multiple of 10, and never exceeds 100.

[align=left]Input[/align]
The first line has a number T (T < 10) , indicating the number of test cases.
For each test case there is a single line with a number x. (0 < x < 100, x is a multiple of 10)

[align=left]Output[/align]
For test case X, output "Case #X:" at the first line. Then output the corresponding interface.
See sample output for more details.

[align=left]Sample Input[/align]

2
0
60

[align=left]Sample Output[/align]

Case #1:
*------------* |............| |............| |............| |............| |............| |............| |............| |............| |............| |............| *------------*
Case #2:
*------------* |............| |............| |............| |............| |------------| |------------| |------------| |------------| |------------| |------------| *------------*

[align=left]Source[/align]
2013 ACM/ICPC Asia Regional Online —— Warmup2

[align=left]Recommend[/align]
zhuyuanchen520

大水题一发

就是拼手速

/* ***********************************************
Author        :kuangbin
Created Time  :2013-9-11 12:01:07
File Name     :2013-9-11\1001.cpp
************************************************ */

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
int iCase = 0;
int T;
int n;
scanf("%d",&T);
while(T--)
{
iCase++;
printf("Case #%d:\n",iCase);
scanf("%d",&n);
printf("*");
for(int i = 0;i < 12;i++)printf("-");
printf("*\n");
int t = n/10;
for(int i = 0;i < 10-t;i++)
{
printf("|");
for(int j = 0;j < 12;j++)printf(".");
printf("|\n");
}
for(int i = 0;i < t;i++)
{
printf("|");
for(int j = 0;j < 12;j++)printf("-");
printf("|\n");
}
printf("*");
for(int i = 0;i < 12;i++)printf("-");
printf("*\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: