您的位置:首页 > 其它

内部比赛 A  Alfredo\'s Pizza Res…

2013-09-11 14:07 302 查看

Alfredo\'s Pizza Restaurant

Time Limit: 1000MS Memory limit: 65536K

题目描述

Traditionally after the Local
Contest, judges and contestants go to their favourite restaurant,
Alfredos Pizza Restaurant. The contestants are really hungry after
trying hard for five hours. To get their pizza as quickly as
possible, they just decided to order one big pizza for all instead
of several small ones. They wonder whether it is possible to put
the big rectangular pizza on the surface of the round table such
that it does not overhang the border of the table. Write a program
that helps them!

输入

The input file contains
several test cases. Each test case starts with an integer number
r, the radius of the surface of the round table the
contestants are sitting at. Input is terminated by r=0.
Otherwise, 1 ≤ r ≤ 1000. Then follow 2 integer numbers
w and l specifying the width and the length of the
pizza, 1 ≤ w ≤ l ≤ 1000.

输出

Output for each test case
whether the ordered pizza will fit on the table or not. Adhere to
the format shown in the sample output. A pizza which just touches
the border of the table without intersecting it is considered
fitting on the table, see example 3 for clarification.

示例输入

38 40 60
35 20 70
50 60 80
0

示例输出

Pizza 1 fits on the table.
Pizza 2 does not fit on the table.
Pizza 3 fits on the table.

这个题纯水题,只要桌子的直径大于Pizza的斜边就行

不罗嗦了代码如下

#include<stdio.h>

#include<string.h>

#include<math.h>

#define MIN 0.000000001

int main()

{

 double r,w,l;

 int num=1;

 while(scanf("%lf%lf%lf",&r,&w,&l),r)

 {

  double x=sqrt(w*w+l*l);

  if(x-r*2>0.0)

  {

   printf("Pizza %d does not fit on the table.\n",num++);

  }

  else

  {

   printf("Pizza %d fits on the table.\n",num++);

  }

 }

 return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: