您的位置:首页 > 其它

hdu 2509 Be the Winner(博弈Nim)

2013-09-11 14:06 393 查看

Be the Winner

Time
Limit: 2000/1000 MS
(Java/Others)    Memory
Limit: 32768/32768 K (Java/Others)Total Submission(s):
573    Accepted
Submission(s): 282
Problem DescriptionLet's consider m apples divided into n groups. Each group contains
no more than 100 apples, arranged in a line. You can take any
number of consecutive apples at one time.For example "@@@" can be turned into "@@" or "@" or "@ @"(two
piles). two people get apples one after another and the one who
takes the last is the loser. Fra wants to know in which situations he can win by
playing strategies (that is, no matter what action the rival takes,
fra will win). InputYou will be given several cases. Each test case begins with a
single number n (1 <= n <= 100),
followed by a line with n numbers, the number of apples in each
pile. There is a blank line between cases. OutputIf a winning strategies can be found, print a single line with
"Yes", otherwise print "No". Sample Input

2
2 1 3 Sample Output
No Yes 
 这题与以往的博弈题的胜负条件不同,谁走完最后一步谁输,但它也是一类NIM游戏,记为anti-nim游戏  首先给出结论:  
 先手胜当且仅当(1)所有堆石子数都为1且游戏的SG值为0 ,(2)存在某堆石子数大于1且游戏的SG值不为0   证明:(1)若所有堆石子数都为1且SG值为0,则共有偶数堆石子,故先手胜。(2)i)只有一堆石子数大于1时,我们总可以对该堆石子操作,使操作后石子堆数为奇数且所有堆得石子数均为1ii)有超过一堆石子数大于1时,先手将SG值变为0即可,且总还存在某堆石子数大于1因而,先手胜。#include<stdio.h>
int a[105];
int main()
{
    int i,ans,n,temp;
   
while(scanf("%d",&n)!=EOF)
    {
     
  temp=0;//孤单堆
     
  for(i=0;i<n;i++)
     
  {
     
     
scanf("%d",&a[i]);
     
     
if(i==0)
     
     
    ans=a[i];
     
      else
     
     
    ans=ans^a[i];
     
     
if(a[i]>1)  temp=1;
     
  }
     
  if(temp==0)
     
  {
     
     
if(n%2==1)
     
     
   printf("No\n");
     
      else
     
     
   printf("Yes\n");
     
     
continue;
     
  }    
    
     
  if(ans==0)
     
   
 printf("No\n");
     
  else
     
   
 printf("Yes\n");
    }  
 
    return 0;
}    
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: