您的位置:首页 > 其它

hdu 1124

2013-09-11 14:05 375 查看

Factorial

Time
Limit: 2000/1000 MS
(Java/Others)    Memory
Limit: 65536/32768 K (Java/Others)Total Submission(s):
1219    Accepted
Submission(s): 779
Problem DescriptionThe most important part of a GSM network is so called Base
Transceiver Station (BTS). These transceivers form the areas called
cells (this term gave the name to the cellular phone) and every
phone connects to the BTS with the strongest signal (in a little
simplified view). Of course, BTSes need some attention and
technicians need to check their function
periodically. ACM technicians faced a very interesting problem recently. Given a
set of BTSes to visit, they needed to find the shortest path to
visit all of the given points and return back to the central
company building. Programmers have spent several months studying
this problem but with no results. They were unable to find the
solution fast enough. After a long time, one of the programmers
found this problem in a conference article. Unfortunately, he found
that the problem is so called "Travelling Salesman Problem" and it
is very hard to solve. If we have N BTSes to be visited, we can
visit them in any order, giving us N! possibilities to examine. The
function expressing that number is called factorial and can be
computed as a product 1.2.3.4....N. The number is very high even
for a relatively small N. The programmers understood they had no chance to solve the problem.
But because they have already received the research grant from the
government, they needed to continue with their studies and produce
at least some results. So they started to study behaviour of the
factorial function. For example, they defined the function Z. For any positive integer
N, Z(N) is the number of zeros at the end of the decimal form of
number N!. They noticed that this function never decreases. If we
have two numbers N1<N2, then Z(N1) <=
Z(N2). It is because we can never "lose" any trailing zero by
multiplying by any positive number. We can only get new and new
zeros. The function Z is very interesting, so we need a computer
program that can determine its value efficiently. InputThere is a single positive integer T on the first line of input. It
stands for the number of numbers to follow. Then there is T lines,
each containing exactly one positive integer number N, 1
<= N <=
1000000000.  OutputFor every number N, output a single line containing the single
non-negative integer Z(N). Sample Input
6 3 60 100 1024 23456 8735373 Sample Output
0 14 24 253 5861 2183837 N! = 1 * 2 * 3 *
(2*2) * 5 * (2*3) * 7... 产生10的原因是有2,5的因子,显然在N!中2的个数大于5的个数,所以只需求出5的个数即可 求 N! (1*2*3*4*5*...*N)里有多少个5其实可以转化成: N!中:是5的倍数的数+是5^2的倍数的数+5^3..... 如50!: 含有10个5的倍数的数:5,15,20,25,30,35,40,45,50
【50/5=10】 含有2个5^2的倍数的数:25,50【50/(5^2)=2】 可见N!中一共有12个5相乘,那么尾0也必有12个 #include<stdio.h>
int main()
{
__int64 f,sum;
int t;
scanf("%d",&t);
while(t--)
{
sum=0;
scanf("%I64d",&f);
while(f)
{
f/=5;
sum+=f;
}
printf("%I64d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: