您的位置:首页 > 其它

HDU 1712 ACboy needs your help 典型的分组背包

2013-09-10 16:27 148 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1712

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3045 Accepted Submission(s): 1581


[align=left]Problem Description[/align]
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?

[align=left]Input[/align]
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.

[align=left]Output[/align]
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

[align=left]Sample Input[/align]

2 2
1 2

1 3

2 2

2 1
2 1

2 3

3 2 1

3 2 1

0 0

[align=left]Sample Output[/align]

3

4

6

解题思路:背包问题,每门课不管多少时间只能选一次,所以是典型的分组背包问题。

想深究可以去看《背包九讲》,把背包问题讲的很详细

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int keng[101][101];
int dp[101];
int main()
{
int n,m,i,j,k;
while(scanf("%d%d",&n,&m),n+m!=0)
{
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++)
for(j=1;j<=m;j++)
{
scanf("%d",&keng[i][j]);
}
for(i=n;i>0;i--)
for(j=m;j>=0;j--)
for(k=1;k<=j;k++)
if(dp[j]<dp[j-k]+keng[i][k])
dp[j]=dp[j-k]+keng[i][k];
printf("%d\n",dp[m]);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: