您的位置:首页 > 产品设计 > UI/UE

poj-------Common Subsequence(poj 1458)

2013-09-08 16:09 274 查看
Common Subsequence

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 34477Accepted: 13631
Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input

abcfbc         abfcab
programming    contest
abcd           mnp

Sample Output

4
2
0

Source

Southeastern Europe 2003

题意:
求两个字符串的最长公共子序列(lcs)的长度。
思路:
金典问题,动态转移方程如下:

if(i==0||j==0)
dp[i][j]=0;
else if(x[i]==y[i])
dp[i][j]=dp[i-1][j-1]+1;
else
dp[i][j]=max(dp[i-1][j],dp[i][j-1]);


代码如下:

#include<iostream>
#include<string>
#include<cmath>
using namespace std;
const int MAX=500;
int dp[MAX][MAX]={0};
int max(int a,int b)
{
return a>b?a:b;
}
int main(int *argv,int *argc[])
{
int len1,len2,i,j;
string str1,str2; //有时在时间允许范围内,用cin读字符串比较方便
while(cin>>str1>>str2)
{
len1=str1.length();
len2=str2.length();
for(i=1;i<=len1;i++)
{
for(j=1;j<=len2;j++)
//转移方程
{
if(str1[i-1]==str2[j-1])
dp[i][j]=dp[i-1][j-1]+1;
else
dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
}
}
cout<<dp[len1][len2]<<endl;
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: