您的位置:首页 > 其它

HDOJ 1564

2013-09-06 01:01 253 查看


Play a game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1130    Accepted Submission(s): 924


Problem Description

New Year is Coming! 

ailyanlu is very happy today! and he is playing a chessboard game with 8600. 

The size of the chessboard is n*n. A stone is placed in a corner square. They play alternatively with 8600 having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can't make
a move will lose the game. If both play perfectly, who will win the game?

 

Input

The input is a sequence of positive integers each in a separate line. 

The integers are between 1 and 10000, inclusive,(means 1 <= n <= 10000) indicating the size of the chessboard. The end of the input is indicated by a zero.

 

Output

Output the winner ("8600" or "ailyanlu") for each input line except the last zero. 

No other characters should be inserted in the output.

 

Sample Input

2
0

 

Sample Output

8600

 

Author

ailyanlu

 

Source

Happy 2007

 

Recommend

8600

 
一道挺水的博弈,一共有n * n个格子,必胜策略为抢占剩余情况为奇数的情况,一开始有n * n - 1种走法,若为奇则先手胜,否则后手胜。
#include <cstdio>
#include <ctime>
#include <cstdlib>
using namespace std;

int main()
{
int n;
while(scanf("%d" , &n) , n)
{
if(n * n % 2 == 0)puts("8600");
else puts("ailyanlu");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM 博弈