您的位置:首页 > 其它

HDU - 1224 - Free DIY Tour

2013-09-05 22:24 435 查看
题目:

Free DIY Tour

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2978 Accepted Submission(s): 982


[align=left]Problem Description[/align]
Weiwei
is a software engineer of ShiningSoft. He has just excellently
fulfilled a software project with his fellow workers. His boss is so
satisfied with their job that he decide to provide them a free tour
around the world. It's a good chance to relax themselves. To most of
them, it's the first time to go abroad so they decide to make a
collective tour.

The tour company shows them a new kind of tour
circuit - DIY circuit. Each circuit contains some cities which can be
selected by tourists themselves. According to the company's statistic,
each city has its own interesting point. For instance, Paris has its
interesting point of 90, New York has its interesting point of 70, ect.
Not any two cities in the world have straight flight so the tour company
provide a map to tell its tourists whether they can got a straight
flight between any two cities on the map. In order to fly back, the
company has made it impossible to make a circle-flight on the half way,
using the cities on the map. That is, they marked each city on the map
with one number, a city with higher number has no straight flight to a
city with lower number.

Note: Weiwei always starts from
Hangzhou(in this problem, we assume Hangzhou is always the first city
and also the last city, so we mark Hangzhou both 1 and N+1), and its interesting point is always 0.

Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?

[align=left]Input[/align]
The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And
then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i
≤ M). Each pair of [Ai, Bi] indicates that a straight flight is
available from City Ai to City Bi.

[align=left]Output[/align]
For
each case, your task is to output the maximal summation of interesting
points Weiwei and his fellow workers can get through optimal DIYing and
the optimal circuit. The format is as the sample. You may assume that
there is only one optimal circuit.

Output a blank line between two cases.

[align=left]Sample Input[/align]

2
3
0 70 90
4
1 2
1 3
2 4
3 4
3
0 90 70
4
1 2
1 3
2 4
3 4

[align=left]Sample Output[/align]

CASE 1#
points : 90
circuit : 1->3->1

CASE 2#
points : 90
circuit : 1->2->1

  题意:给你一些点(n个),然后每个点都有一个权值,每走到一个点就可以得到这个点这么多的价值,然后给出边,问你从起点(1号点)走到第n+1号点,怎样走才可以使得到的价值最大,同时打印路径。同时还规定了这个图有某些特殊条件,1、只存在从编号小的点去到编号大的点,2、起点的价值为0。
  这一题一开始读错了题,以为是只可以从标号小的点去到编号大的点,于是就以为要用差分约束来做,后来才发现是读错题了= =,如果按照正确的题意来理解的话就会变成这样,图上面的边都是有向边,同时不存在环。然后,然后这一题就瞬间变成普通的最短路了= =,只是多了一个打印路径,这里我用的是递归的写法,主要是因为这里的点不多。
  因为一开始格式不对贡献了几个WA,看来以后要小心= =。

代码:

#include <cstdio>
#include <cstring>
#include <queue>
#define MAX 50010
#define INF 1000000000
using namespace std;

typedef struct
{
int to,l,next;
}node;

node N[MAX];
int head[110],dis[110],val[110],per[110],tot,n;

void add(int u,int v)
{
N[tot].to=v; N[tot].l=val[v]; N[tot].next=head[u]; head[u]=tot++;
}

void Init()
{
memset(N,0,sizeof(N));
memset(head,-1,sizeof(head));
memset(val,0,sizeof(val));
memset(per,-1,sizeof(per));
tot=0;
}

void spfa()
{
int i,u;
queue<int> q;
bool vin[110];
for(i=2;i<=n+1;i++) dis[i]=-INF;
dis[1]=0;
memset(vin,0,sizeof(vin));
q.push(1);
vin[1]=1;
while(!q.empty())
{
u=q.front();
q.pop();
vin[u]=0;
for(i=head[u];i!=-1;i=N[i].next)
{
int len;
len=dis[u]+N[i].l;
if(dis[N[i].to]<len)
{
dis[N[i].to]=len;
per[N[i].to]=u;
if(!vin[N[i].to])
{
q.push(N[i].to);
vin[N[i].to]=1;
}
}
}
}
}

void print_path(int e)
{
if(per[e]>0) print_path(per[e]);
if(e==n+1) printf("1");
else
{
printf("%d->",e);
}
}

int main()
{
int i,j,t,m,a,b;
//freopen("data.txt","r",stdin);
scanf("%d",&t);
for(i=0;i<t;)
{
Init();
scanf("%d",&n);
for(j=1;j<=n;j++) scanf("%d",&val[j]);
scanf("%d",&m);
for(j=0;j<m;j++)
{
scanf("%d %d",&a,&b);
add(a,b);
}
spfa();
i++;
printf("CASE %d#\n",i);
printf("points : %d\n",dis[n+1]);
printf("circuit : ");
print_path(n+1);
printf("\n");
if(i!=t) printf("\n");
}
return 0;
}


1224
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: