您的位置:首页 > 其它

Leftmost Digit HDU 1060

2013-09-05 10:16 471 查看

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 11062 Accepted Submission(s): 4228 [align=left]Problem Description[/align]Given a positive integer N, you should output the leftmost digit of N^N. [align=left]Input[/align]The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains a single positive integer N(1<=N<=1,000,000,000). [align=left]Output[/align]For each test case, you should output the leftmost digit of N^N. [align=left]Sample Input[/align]2 3 4

[align=left]Sample Output[/align]
2
2


#include <cstdio>
#include <iostream>
#include <cmath>
using namespace std;
int main(){
int n,m;long long b;
double sum,a;
scanf("%d",&m);
while(m--)
{
scanf("%d",&n);
a=n*log10(n/1.0);b=(long long)a;
sum=pow(10.0,(a-b));
printf("%d\n",(int)sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: