您的位置:首页 > 产品设计 > UI/UE

UVa 11039 Building designing (模拟)

2013-09-01 22:20 253 查看


11039 - Building designing

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=457&page=show_problem&problem=1980

An architect wants to design a very high building. The building will consist of some floors, and each floor has a certain size. The size of a floor must be greater than the size of the floor immediately above it. In
addition, the designer (who is a fan of a famous Spanish football team) wants to paint the building in blue and red, each floor a colour, and in such a way that the colours of two consecutive floors are different.
To design the building the architect has n available floors, with their associated sizes and colours. All the available floors
are of different sizes. The architect wants to design the highest possible building with these restrictions, using the available floors.

Input

The input file consists of a first line with the number p of cases to solve. The first line of each case contains the number
of available floors. Then, the size and colour of each floor appear in one line. Each floor is represented with an integer between -999999 and 999999. There is no floor with size 0. Negative numbers represent red floors and positive numbers blue floors. The
size of the floor is the absolute value of the number. There are not two floors with the same size. The maximum number of floors for a problem is 500000.

Output

For each case the output will consist of a line with the number of floors of the highest building with the mentioned conditions.

Sample Input

2
5
7
-2
6
9
-3
8
11
-9
2
5
18
17
-15
4


Sample Output

2
5


water.

完整代码:

/*0.072s*/

#include<cstdio>
#include<algorithm>
using namespace std;

struct Floor
{
	bool blue;
	int size;
	bool operator < (const Floor &f) const
	{
		return size < f.size;
	}
} floor[500010];

int main(void)
{
	int p, temp;
	scanf("%d", &p);
	while (p--)
	{
		int n;
		scanf("%d", &n);
		for (int i = 0; i < n; ++i)
		{
			scanf("%d", &temp);
			floor[i] = temp > 0 ? (Floor){true, temp} : (Floor){false, -temp};
		}
		sort(floor, floor + n);
		
		bool nowblue = floor[0].blue;
		int count = 1;
		for (int i = 1; i < n; ++i)
		{
			if (floor[i].blue != nowblue)
			{
				nowblue = !nowblue;
				++count;
			}
		}
		printf("%d\n", count);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: