您的位置:首页 > 其它

hdu 1060 Leftmost Digit

2013-08-28 20:57 190 查看


Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11006    Accepted Submission(s): 4213


Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 

Output

For each test case, you should output the leftmost digit of N^N.

 

Sample Input

2
3
4

 

Sample Output

2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

 
题目大意:给一个数n,求出n^n的最左边的数。
思路:
 设n的位数为k,则 k=[n*log10(n)]+1;
令n^n=a.xxx*10^(k-1); 我们要求的即是a。
两边同时取对数,则n*log10(n)=log10(a.xxx)+k-1;
a.xxx=10^(n*log10(n)-k+1);
则a=[10^(n*log10(n)-k+1)]
=[10^(n*log10(n)-([n*log10(n)]+1)+1)]
=[10^(n*log10(n)-[n*log10(n)]]。。。

#include<iostream>
#include <cstdio>
#include<cstring>
#include<algorithm>
#include <cmath>
using namespace std;

int main()
{
int n,t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
double sum=0.0;

sum=n*log10(n*1.0);
int ans=(int)pow(10.0,sum-(long long)sum);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM C hdu