您的位置:首页 > 其它

UVA 11584 Partitioning by Palindromes (回文DP,4级)

2013-08-28 16:30 309 查看
A - Partitioning by Palindromes
Crawling in process...Crawling failedTime
Limit:
1000MS Memory Limit:0KB
64bit IO Format:%lld & %llu
SubmitStatus

Appoint description:
System Crawler (2013-05-30)

Description





Problem H: Partitioning by Palindromes



We say a sequence of characters is a palindrome if it is the same written forwards and backwards. For example, 'racecar' is a palindrome, but 'fastcar' is not.

A partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, ('race', 'car') is a partition of 'racecar' into two groups.

Given a sequence of characters, we can always create a partition of these characters such that each group in the partition is a palindrome! Given this observation it is natural to ask: what is the minimum number of groups needed for a given string such that
every group is a palindrome?

For example:

'racecar' is already a palindrome, therefore it can be partitioned into one group.
'fastcar' does not contain any non-trivial palindromes, so it must be partitioned as ('f', 'a', 's', 't', 'c', 'a', 'r').
'aaadbccb' can be partitioned as ('aaa', 'd', 'bccb').

Input begins with the number n of test cases. Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.

For each test case, output a line containing the minimum number of groups required to partition the input into groups of palindromes.

Sample Input

3
racecar
fastcar
aaadbccb

Sample Output

1
7
3


Kevin Waugh

一个串最少分成几个回文串
思路:先标记回文串,然后扫一遍DP

#include<cstring>
#include<cstdio>
#include<iostream>
#define FOR(i,a,b) for(int i=a;i<=b;++i)
#define clr(f,z) memset(f,z,sizeof(f))
using namespace std;
const int mm=1009;
char s[mm];
bool isp[mm][mm];
int dp[mm];
int main()
{
int cas;
while(~scanf("%d",&cas))
{
while(cas--)
{ clr(isp,0);
scanf("%s",s);
int len=strlen(s);
FOR(i,0,len)isp[i+1][i]=isp[i+2][i]=1;
for(int i=len;i>0;--i)
FOR(j,i,len)
if(isp[i+1][j-1]&&s[i-1]==s[j-1])isp[i][j]=true;
dp[0]=0;
FOR(i,1,len)
{
dp[i]=mm;
FOR(j,1,i)
if(isp[j][i])
dp[i]=min(dp[i],dp[j-1]+1);
}
printf("%d\n",dp[len]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: