您的位置:首页 > 其它

UVALive 2038 Strategic game (树形DP,4级)

2013-08-28 16:18 543 查看
L - Strategic gameCrawling in process...Crawling failedTime Limit:3000MSMemory Limit:0KB 64bit IO Format:%lld & %lluSubmitStatusAppoint description:System Crawler (2013-06-01)DescriptionBob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to putthe minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?Your program should find the minimum number of soldiers that Bob has to put for a given tree.For example for the tree:the solution is one soldier (at the node 1).InputThe input file contains several data sets in text format. Each data set represents a tree with the following description:
the number of nodesthe description of each node in the following format:node_identifier:(number_of_roads) node_identifier1 node_identifier2 … node_identifiernumber_of_roadsornode_identifier:(0)
The node identifiers are integer numbers between 0 and n-1, forn nodes (0 < n ≤ 1500). Every edge appears only once in the input data.OutputThe output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers).Sample Input
4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)
Sample Output
1
2
思路:简单树形DP dp[u][0]不选dp[u][1]选。
dp[u][1]+=min(dp[v][0],dp[v][1])
dp[u][0]+=dp[v][1];
数据生成器
#include<iostream>
#include<cstdio>
#include<cstring>
#include<ctime>
#include<cstdlib>
using namespace std;
bool vis[1600][1600];
int main()
{
int n;
memset(vis,0,sizeof(vis));
for(int i=0;i<=1503;++i)vis[i][i]=1;
srand((int)time(0));
n=rand()%1500+1;printf("%d\n",n);
int z=n;
for(int i=0;i<n;++i)
{
int zz=rand()%100;
if(z>zz)
z-=zz;
else zz=0;
printf("%d:(%d)",i,zz);
int k=0;
for(int j=0;j<zz;++j)
{ while(k<n&&vis[i][k])++k;
printf(" %d",k);vis[i][k]=vis[k][i]=1;
}
printf("\n");
}
}
对拍程序[/code]
@echo off:looprand.exe>data.txtstd.exe<data.txt>std.txtmy.exe<data.txt>my.txtfc my.txt std.txtif not errorlevel 1 goto looppausegoto loop
代码[/code]
#include<cstring>#include<iostream>#include<cstdio>#define FOR(i,a,b) for(int i=a;i<=b;++i)#define clr(f,z) memset(f,z,sizeof(f))using namespace std;const int mm=1502;const int oo=0x3f3f3f3f;int head[mm],edge;int dp[mm][2];class Edge{public:int v,next;}e[mm*mm];void data(){edge=0;clr(head,-1);}void add(int u,int v){e[edge].v=v;e[edge].next=head[u];head[u]=edge++;}int DP(int u,int fa,int yes){ int v;if(dp[u][yes]!=-1)return dp[u][yes];dp[u][yes]=yes;for(int i=head[u];~i;i=e[i].next){v=e[i].v;if(v==fa)continue;if(yes)dp[u][yes]+=min(DP(v,u,0),DP(v,u,1));else dp[u][yes]+=DP(v,u,1);}return dp[u][yes];}int main(){int n,a,b,m;while(~scanf("%d",&n)){data();FOR(i,1,n){scanf("%d",&a);scanf(":(%d)",&m);FOR(j,1,m){scanf("%d",&b);add(a,b);add(b,a);//cout<<a<<" "<<b<<endl;}}clr(dp,-1);int ans=min(DP(0,-1,0),DP(0,-1,1));printf("%d\n",ans);}}
[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: