您的位置:首页 > 其它

hdu 题目1171 Big Event in HDU(母函数及其应用)

2013-08-28 09:51 369 查看


Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 19055    Accepted Submission(s): 6695


Problem Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).

 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the
facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.

 

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

 

Sample Input

2
10 1
20 1
3
10 1
20 2
30 1
-1

 

Sample Output

20 10
40 40

 

facilities个数n,

每个的价值为 v[i];

每个的数量为m[i];

母函数为



/***************************
# 2013-8-28 9:39:05
# Time: 281MS Memory: 2180KB
# Author: zyh
# Status: Accepted
***************************/

#include<stdio.h>

int c1[250005],c2[250005],v[51],m[51];
int main()
{
int n,i,j,k,sum;

while(scanf("%d",&n)!=EOF && n>0)
{
for(i=1;i<=n;i++){
scanf("%d%d",&v[i],&m[i]);
}
memset(c1,0,sizeof(c1));
memset(c2,0,sizeof(c2));
for(i=0;i<=v[1]*m[1]; i+= v[1]) //初始化c1
c1[i]=1;

sum=0;
sum = v[1]*m[1];
for(i=2;i<=n;i++){
for(j=0;j<=sum;j++){ //sum代表每次乘积的项数的目
for(k=0;k<=v[i]*m[i]; k+=v[i])
c2[j+k] += c1[j];
}
sum += v[i]*m[i];
for(j=0;j<=sum;j++){
c1[j] = c2[j];
c2[j] = 0;
}
}

for(i=sum/2;i>=0;i--){
if(c1[i]){
printf("%d %d\n",sum-i,i);
break;
}
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: