您的位置:首页 > 其它

1036. Boys vs Girls (25)

2013-08-27 23:03 330 查看
This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters
with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM.
If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

Sample Input 1:
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:
Mary EE990830
Joe Math990112
6

Sample Input 2:
1
Jean M AA980920 60

Sample Output 2:
Absent
Jean AA980920
NA

http://pat.zju.edu.cn/contests/pat-a-practise/1036

题意输入是一批学生的成绩,要求找出其中男生最低的成绩和女生最高的成绩,求其间的差值。如果无法计算,则输出 NA.分析简单模拟题。
#include <iostream>
#include <vector>
#include <string>

typedef struct Student
{
char name[20];
char gender;
char id[20];
int g;
}Student;

bool ValidGrade (int g)
{
if(g >= 0 && g <= 100)
return true;
else return false;
}

int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
Student female,male;
female.g=-1;
male.g=101;
Student tmp;

while (n--)
{

scanf("%s %c %s %d",&tmp.name,&tmp.gender,&tmp.id,&tmp.g);
if(tmp.gender=='F'&&tmp.g>female.g)
female=tmp;
else if(tmp.gender=='M'&&tmp.g <male.g)
male=tmp;
}
if(ValidGrade(female.g))
printf("%s %s\n",female.name,female.id);
else printf("Absent\n");
if(ValidGrade(male.g))
printf("%s %s\n",male.name,male.id);
else printf("Absent\n");
if(ValidGrade(female.g)&&ValidGrade(male.g))
printf("%d\n",female.g-male.g);
else printf("NA\n");
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: