您的位置:首页 > 移动开发

1452 Happy 2004 (所有因子求和)

2013-08-27 20:37 246 查看

Happy 2004

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 837 Accepted Submission(s): 586


[align=left]Problem Description[/align]
Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29).

Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6.

[align=left]Input[/align]
The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000).

A test case of X = 0 indicates the end of input, and should not be processed.

[align=left]Output[/align]
For each test case, in a separate line, please output the result of S modulo 29.

[align=left]Sample Input[/align]

1
10000
0


[align=left]Sample Output[/align]

6
10 思路分析:设S(x)表示x的因子和。则题目求为:S(2004^X)mod 29
因子和S是积性函数,即满足性质1。性质1 :如果 gcd(a,b)=1 则 S(a*b)= S(a)*S(b)
2004^X=4^X * 3^X *167^X
S(2004^X)=S(2^(2X)) * S(3^X) * S(167^X)性质2 :如果 p 是素数 则 S(p^X)=1+p+p^2+...+p^X = (p^(X+1)-1)/(p-1)
因此:S(2004^X)=(2^(2X+1)-1) * (3^(X+1)-1)/2 * (167^(X+1)-1)/166
167%29 == 22
S(2004^X)=(2^(2X+1)-1) * (3^(X+1)-1)/2 * (22^(X+1)-1)/21性质3 :(a*b)/c %M= a%M * b%M * inv(c)
其中inv(c)即满足 (c*inv(c))%M=1的最小整数,这里M=29
则inv(1)=1,inv(2)=15,inv(22)=15有上得:
S(2004^X)=(2^(2X+1)-1) * (3^(X+1)-1)/2 * (22^(X+1)-1)/21
=(2^(2X+1)-1) * (3^(X+1)-1)*15 * (22^(X+1)-1)*18快速幂取模就是在O(logn)内求出a^n mod b的值。算法的原理是ab mod c=(a mod c)(b mod c)mod c  代码#include<iostream>
using namespace std;
const int pow[][3]={{2,5,32},{3,4,81},{22,2,484}};
//2^5>29,3^4>29,22^2>29,用于求(b^i)%29
int PowMod29(int x,int index)   //快速模幂
{
int ans=1;
while(index>=pow[x][1]) //当指数大于这个值将会超过29
{
ans=(ans*pow[x][2])%29;  //所以要模29.并且要乘上前面的值!
index-=pow[x][1];
}
while(index--) ans=(ans*pow[x][0])%29;//把剩余的不超过29的乘上!再记得模上29(因为有可能超过29)
return ans;
}
int main()
{
int X,part2,part3,part167;
while(cin>>X&&X!=0)
{
part2=PowMod29(0,2*X+1);
part3=PowMod29(1,X+1);
part167=PowMod29(2,X+1);
cout<<((part2-1)*(part3-1)*15*(part167-1)*18)%29<<endl;//再模29,因为有超过29的可能.
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: