您的位置:首页 > 编程语言 > C语言/C++

SOJ 1310. Right-Heavy Tree

2013-08-26 00:21 246 查看
Description

A right-heavy tree is a binary tree where the value of a node is greater than or equal to the values of the nodes in its left subtree and less than the values of the nodes in its right subtree. A right-heavy tree could be empty.

Write a program that will create a right-heavy tree from a given input sequence and then traverse the tree and printing the value of the node each time a node is visited using inorder, preorder and postorder traversal.

The program should create the nodes in the tree dynamically. Thus, basically the tree can be of any size limited only by the amount of memory available in the computer.

Input

The input will contain several test cases, each of them as described below.

The first number in the input indicates the number of nodes in the tree. Then, the input is followed by the integers comprising the values of the nodes of the tree.

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line. The output will be the sequence of node and labeled by the traversal method used, as shown in the sample output below.

Sample Input
 Copy sample input to clipboard

8 8 2 4 7 5 3 1 6
9 5 5 6 3 2 9 3 3 2
8 4 2 1 4 3 2 5 1
0


Sample Output

Inorder: 1 2 3 4 5 6 7 8
Preorder: 8 2 1 4 3 7 5 6
Postorder: 1 3 6 5 7 4 2 8

Inorder: 2 2 3 3 3 5 5 6 9
Preorder: 5 5 3 2 2 3 3 6 9
Postorder: 2 3 3 2 3 5 9 6 5

Inorder: 1 1 2 2 3 4 4 5
Preorder: 4 2 1 1 2 4 3 5
Postorder: 1 2 1 3 4 2 5 4

Inorder:
Preorder:
Postorder:


Hint

The number of vertexs is no more than 200000.

#include<iostream>
#include<memory.h>
using namespace std;
struct BT{

struct RHT
{
int data;
RHT *left;
RHT *right;
RHT(int a,RHT *left=NULL, RHT *RHT=NULL):data(a),left(left),right(right) {}

};
RHT *root;
BT()
{
root=NULL;
}
void insert(const int & dat )
{
return ins(root,dat);
}
void ins(RHT * & root,const int & dat)
{
if(root != NULL)
{
if(root->data>=dat)
ins(root->left,dat);
else ins(root->right,dat);
}
else root = new  RHT(dat);//for pointer's ,you must new operator
}
void Inorder(RHT * &root)
{
if(root!=NULL)
{
Inorder(root->left);
cout<<" "<<root->data;
Inorder(root->right);
}

}
void Preorder(RHT * &root)
{
if(root!=NULL)
{
cout<<" "<<root->data;
Preorder(root->left);
Preorder(root->right);
}
}
void Postorder(RHT * &root)
{
if(root!=NULL)
{
Postorder(root->left);
Postorder(root->right);
cout<<" "<<root->data;
}
}
};
int main()
{
int n;
bool first=true;
int temp=0;
while(cin>>n)
{
if(!first)
cout<<endl;
first=false;
BT bt;
for (int i = 0; i < n; ++i)
{
cin>>temp;
bt.insert(temp);
}
cout<<"Inorder:";
bt.Inorder(bt.root);
cout<<endl;
cout<<"Preorder:";
bt.Preorder(bt.root);
cout<<endl;
cout<<"Postorder:";
bt.Postorder(bt.root);
cout<<endl;
}
return 0;
}
,这一个版本用了0.79sec,之前写了一个版本的,可能是因为没有按地址传递,所以TLE了。构造树和前序中序后序遍历其实挺容易的。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  构造RHT树 C++ SOJ