您的位置:首页 > 其它

2013资格赛——Next Round

2013-08-24 16:29 197 查看
Description
"Contestant who earns a score equal to or greater than the k-th place finisher's score will advance to the next round, as long as the contestant earns a positive score..." — an excerpt from contest rules.

A total of n participants took part in the contest (n ≥ k), and you already know their scores. Calculate how many participants will advance to the next round.

Input
The first line of the input contains two integers n and k (1 ≤ k ≤ n ≤ 50) separated by a single space.

The second line contains n space-separated integers a1, a2, ..., an (0 ≤ ai ≤ 100), where ai is the score earned by the participant who got the i-th place. The given sequence is non-increasing (that is, for all i from 1 to n - 1 the following
condition is fulfilled: ai ≥ ai + 1).

Output
Output the number of participants who advance to the next round.

Sample Input
8 5

10 9 8 7 7 7 5 5

Sample Output
6

Note
In the example the participant on the 5th place earned 7 points. As the participant on the 6th place also earned 7 points, there are 6 advancers.

Source
CodeForces
分析:水题。
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int main()
{
int n,k,i,j,ta,sum;
while(~scanf("%d%d",&n,&k))
{
sum=0;
for(i=0;i<k;i++)
{
scanf("%d",&ta);
sum=ta>0?sum+1:sum;
}
for(;i<n;i++)
{
scanf("%d",&j);
if(j>=ta&&j>0)
sum+=1;
}
printf("%d\n",sum);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: