您的位置:首页 > 其它

ZOJ 1542 Network

2013-08-24 12:58 357 查看
题意:给你N个点M条边,求最小生成树,并且输出最小生成树里最大的那条边,并且输出路径 

Network
Time Limit: 2 Seconds      Memory Limit: 65536 KB      Special Judge

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables.
Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).

Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem - not each hub can be connected to any other one
because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections.

You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.

Input
The first line of the input file contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000).
All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed
10^6. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.
Process to the end of file.

Output
Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then
output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input
4 6

1 2 1

1 3 1

1 4 2

2 3 1

3 4 1

2 4 1

Sample Output
1

4

1 2

1 3

2 3

3 4
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>

using namespace std;

int dp[20010], f[20010];
struct Edge
{
int u, v, w;
} edge[20010];

int m, _min, cnt;
int cmp(Edge a, Edge b)
{
return a.w < b.w;
}
int find(int x)
{
while(x != f[x])
x = f[x];
return x;
}
void merger()
{
int x, y, i;
for(i = 0; i < m; i++)
{
x = find(edge[i].u);
y = find(edge[i].v);
if(x != y)
{
f[y] = x;
if(_min < edge[i].w)//这里不判断也能A不知道为什啊?
_min = edge[i].w;
dp[cnt++] = i;
}
}
}
int main()
{
int i, n;
while(~scanf("%d %d",&n, &m))
{
for(i = 0; i <= n; i++)
f[i] = i;
for(i = 0; i < m; i++)
scanf("%d %d %d",&edge[i].u, &edge[i].v, &edge[i].w);
sort(edge , edge+m, cmp);
cnt = _min = 0;
merger();
printf("%d\n%d\n",_min, cnt);
for(i = 0; i < cnt; i++)
printf("%d %d\n",edge[dp[i]].u, edge[dp[i]].v);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM zoj