您的位置:首页 > 其它

Color the ball (树状数组)

2013-08-24 10:41 218 查看

Color the ball

Time Limit : 9000/3000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 4

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

Input

每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。

当N = 0,输入结束。

Output

每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

Sample Input

3
1 1
2 2
3 3
3
1 1
1 2
1 3
0


Sample Output

1 1 1
3 2 1


Author

8600

Source

HDU 2006-12 Programming Contest

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
using namespace std;
int s[100010];
int n;
int lowbit(int x)
{
return x&(-x);
}
void add(int x,int data)
{
while(x>0)
{
s[x]+=data;
x-=lowbit(x);
}
}
int query(int x)
{
int sum=0;
while(x<=n)
{
sum+=s[x];
x+=lowbit(x);
}
return sum;
}
int main()
{
int i,a,b;
while(scanf("%d",&n),n)
{
memset(s,0,sizeof(s));
for(i=1;i<=n;i++)
{
scanf("%d%d",&a,&b);
add(b,1);
add(a-1,-1);
}
for(i=1;i<=n-1;i++)
{
printf("%d ",query(i));
}
printf("%d\n",query(n));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Color the ball