您的位置:首页 > 其它

Kids and Prizes(SGU495,概率DP)

2013-08-22 21:37 441 查看
http://acm.sgu.ru/problem.php?contest=0&problem=495

495. Kids and Prizes

ICPC (International Cardboard Producing Company) is in the business of producing cardboard boxes. Recently the company organized a contest for kids for the best design of a cardboard box and selected M winners. There are N prizes for the winners, each one carefully packed in a cardboard box (made by the ICPC, of course). The awarding process will be as follows:

All the boxes with prizes will be stored in a separate room.

The winners will enter the room, one at a time.

Each winner selects one of the boxes.

The selected box is opened by a representative of the organizing committee.

If the box contains a prize, the winner takes it.

If the box is empty (because the same box has already been selected by one or more previous winners), the winner will instead get a certificate printed on a sheet of excellent cardboard (made by ICPC, of course).

Whether there is a prize or not, the box is re-sealed and returned to the room.

The management of the company would like to know how many prizes will be given by the above process. It is assumed that each winner picks a box at random and that all boxes are equally likely to be picked. Compute the mathematical expectation of the number of prizes given (the certificates are not counted as prizes, of course).

Input

The first and only line of the input file contains the values of N and M ().

Output

The first and only line of the output file should contain a single real number: the expected number of prizes given out. The answer is accepted as correct if either the absolute or the relative error is less than or equal to 10-9.

Example(s)

sample input

sample output

5 7

3.951424

sample input

sample output

4 3

2.3125

解析:

题意:

有n个奖品放在n个盒子,进行m次选择,每次只能选则一个盒子,如果选到含有奖品的话就把盒子里奖品拿走,盒子始终仍留着。问最终得到到奖品数的期望值。

思路:

刚开始时想复杂了,我每次选择都看做与上一次选择相关的条件概率

看了zhsl的博客才发现这可以转化为我们平时做数学题的一种思维。

通过求逆事件得到结果。

1.每次取时盒子总数总是不变,因此样本空间始终为n。

2.考虑一次取时一个奖品未被拿走的情况有(n-1)种,其概率始终为(n-1)/n;

3.因为每次取盒子的事件为独立事件,所以取m次一个奖品未被取走的概率为((n-1)/n)^m;

4.所要求的期望值为n-((n-1)/n)^m;

还有一种递推法:

参考来自zhsl:http://www.cnblogs.com/zhsl/archive/2013/08/12/3253858.html

15 MS 887 KB GNU C++

*/#include<stdio.h>

#include<string.h>
#include<math.h>
#include<algorithm>
#include <iostream>
using namespace std;
const int maxn=100000+10;
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
double ans;
ans=n*1.0-n*1.0*pow((n-1)*1.0/n,m);
printf("%.10lf\n",ans);//输出的时候注意精度
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: