您的位置:首页 > 编程语言 > C语言/C++

【PAT】1058. A+B in Hogwarts (20)

2013-08-22 21:30 429 查看
题目:http://pat.zju.edu.cn/contests/pat-a-practise/1058

分析:注意输入格式即可简单解题。

题目描述:

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program
to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27

Sample Output:
14.1.28


#include<iostream>
using namespace std;
int main()
{
int G,G1,S,S1,K,K1;
char t;
cin>>G>>t>>S>>t>>K;
cin>>G1>>t>>S1>>t>>K1;
K += K1;
S += K/29;
K %= 29;

S += S1;
G += S/17;
S %= 17;

G += G1;

cout<<G<<"."<<S<<"."<<K<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT cc++