您的位置:首页 > 其它

A:Alice and Bob

2013-08-22 21:16 288 查看


Alice and Bob

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1395 Accepted Submission(s): 508



Problem Description

Alice and Bob are very smart guys and they like to play all kinds of games in their spare time. The most amazing thing is that they always find the best strategy, and that's why they feel bored again and again. They just invented a new game, as they usually
did.

The rule of the new game is quite simple. At the beginning of the game, they write down N random positive integers, then they take turns (Alice first) to either:

1. Decrease a number by one.

2. Erase any two numbers and write down their sum.

Whenever a number is decreased to 0, it will be erased automatically. The game ends when all numbers are finally erased, and the one who cannot play in his(her) turn loses the game.

Here's the problem: Who will win the game if both use the best strategy? Find it out quickly, before they get bored of the game again!

Input

The first line contains an integer T(1 <= T <= 4000), indicating the number of test cases.

Each test case contains several lines.

The first line contains an integer N(1 <= N <= 50).

The next line contains N positive integers A1 ....AN(1 <= Ai <= 1000), represents the numbers they write down at the beginning of the game.

Output

For each test case in the input, print one line: "Case #X: Y", where X is the test case number (starting with 1) and Y is either "Alice" or "Bob".

Sample Input

3
3
1 1 2
2
3 4
3
2 3 5


Sample Output

Case #1: Alice
Case #2: Bob
Case #3: Bob


Source

2011 Asia ChengDu Regional Contest

Recommend

Statistic | Submit | Discuss | Note

dp[i][j]表示有i个数是1,消去不为1的其他数字要j步(把数字减小和合并数字),为1表示先手赢,为0表示后手赢,为-1表示还没算出来

枚举找失败态.

dp数组一直保存下来记忆化;

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#define M 60
#define LL long long
using namespace std;

int a[55];
int dp[55][55*1000];

int cl(int i,int j){
if(dp[i][j]!=-1) return dp[i][j];
if(j==1) return dp[i][j]=cl(i+1,0);
dp[i][j]=0;
if(i>=1 && !cl(i-1,j)) dp[i][j]=1;

else if(i>=1 && j>=1 && !cl(i-1,j+1)) dp[i][j]=1;

else if(i>=2 && j>0 && !cl(i-2,j+3)) dp[i][j]=1;
else if(i>=2 && j==0 && !cl(i-2,2)) dp[i][j]=1;

else if(j>=2 && !cl(i,j-1)) dp[i][j]=1;
return dp[i][j];
}

int main(){
int T,cas=1;
memset(dp,-1,sizeof(dp));
cin>>T;
while(T--){
int n,i,sum=0,n1=0;
cin>>n;
for(i=0;i<n;i++){
cin>>a[i];
if(a[i]==1) n1++;
sum+=a[i];
}
int j=n1,k=sum-n1+n-n1-1;
if(k<0) k++;
cl(j,k);
cout<<"Case #"<<cas++<<": ";
if(dp[j][k]) puts("Alice");
else puts("Bob");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: