您的位置:首页 > 其它

UVAlive 2322 Wooden Sticks(贪心)

2013-08-22 18:23 363 查看
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

The setup time for the first wooden stick is 1 minute.

Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <=l' and w <=w' .

Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of
n
wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4) then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of
T
test cases. The number of test cases (
T
) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer
n
, 1<=
n<=
5000, that represents the number of wooden sticks in the test case, and the second line contains 2
n
positive integers
l1
,
w1
,
l2
,
w2
, ...,
ln
,
wn
, each of magnitude at most 10000, where
li
and
wi
are the length and weight of the
i
th wooden stick, respectively. The 2
n
integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

Sample Output

2
1
3

题意: 给定n个木棍,每个木棍有重量w和长度l。现在要加工木棍。每次加工木棍要设置一下,如果下次加工的木棍重量长度w'、l‘和当前木棍加工长度w、l满足条件。w'>=w 和 l'>=l就不需要重新设置。求最少设置次数。

思路:贪心。把木棍按w从小到大排序。相同的按l从小到大排序。然后开一个标记数组。已经加工过的标记掉。每次从开头找到一根未加工的。去寻求最多不用重新设置可以加工掉的木棍。全部加工掉。直到全部加工掉。

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int t, n, time;
struct Strick {
int l, w, v;//v用来标记
} s[5005];

int cmp(Strick a, Strick b) {
if (a.l != b.l)
return a.l < b.l;
return a.w < b.w;
}

int main() {
scanf("%d", &t);
while (t --) {
time = 0;
memset(s, 0, sizeof(s));
scanf("%d", &n);
for (int i = 0; i < n; i ++)
scanf("%d%d", &s[i].l, &s[i].w);
sort(s, s + n, cmp);
for (int i = 0; i < n; i ++) {
if (s[i].v) continue;
int sb = s[i].w;
time ++;
for (int j = i; j < n; j ++)
if (s[j].w >= sb && !s[j].v) {
sb = s[j].w;
s[j].v = 1;
}
}
printf("%d\n", time);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: