您的位置:首页 > 其它

HDU 1541 Stars (树状数组)

2013-08-22 17:32 489 查看
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given
star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

[align=left]Input[/align]
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one
point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

[align=left]Output[/align]
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

[align=left]Sample Input[/align]

5
1 1
5 1
7 1
3 3
5 5

[align=left]Sample Output[/align]

1
2
1
1
0题目大意:输入一个n,再输入n个数的坐标。如果星星左下方(包括左,下)没有星星,那这个星星就是level 0,如果有1个星星,这个星星就是level 1 以此类推。。。要求输出n个数的(0---n-1)的level。。。思路:这个题目开始当做二维做了,没做出来,后来发现这句话Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. (意思就是,输入坐标按Y增长,如果Y相等,就按X增长)...所以,的出个结论,只要小于等于X坐标(因为Y是有小到大输入的)的星星,都比当前level小...且前面所有星星的个数就是当前X星星的level。有了这个结论就可以AC了...下面上代码。
#include<stdio.h>
#include<string.h>
int c[32000+10];
int a[15000+10];
int lowbit(int x)
{
return x&(-x);
}
void updata(int x,int d)
{
while(x<=32001)
{
c[x]=c[x]+d;
x=x+lowbit(x);
}
}
int getsum(int x)
{
int res = 0;
while(x>0)
{
res=res+c[x];
x=x-lowbit(x);
}
return res;
}
int main()
{
int n;
int i,x,y;
while(scanf("%d",&n)!=EOF)
{
memset(c,0,sizeof(c));
memset(a,0,sizeof(a));
for(i=0; i<n; i++)
{
//因为y是升序,所以横坐标小于x的,(想了很久)所有点都符合,这是解这道题的关键。
scanf("%d%d",&x,&y);    //下标可能从0开始,所以要x+1
a[getsum(x+1)]++;       //求出横坐标小于x的所有stars个数,并记录到a中
updata(x+1,1);          //更新区间
}
for(i=0; i<n; i++)
{
printf("%d\n",a[i]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: