您的位置:首页 > 其它

HD 2062 Bone Collector 解题报告

2013-08-22 16:15 309 查看

Bone Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 22108 Accepted Submission(s): 8947


[align=left]Problem Description[/align]
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



[align=left]Input[/align]
The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

[align=left]Output[/align]
One integer per line representing the maximum of the total value (this number will be less than 231).

[align=left]Sample Input[/align]

1
5 10
1 2 3 4 5
5 4 3 2 1

[align=left]Sample Output[/align]

14
解题分析典型的背包问题,背包容量为v,骨头个数为n。思路,选择质量小于背包当前容量的骨头,且使选择此骨头后的价值比不选择时价值高。动态转移方程 f[j]=max(f[j],f[j-bone[i].vol]+bone[i].val) bool[i].vol表示第i块骨头的质量,bool[i].val表示第i块骨头的价值。
解题代码
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
//此题参考别人的解题报告才做出来,确实有点没有理解这个过程
int mymax(int a,int b)
{
if(a<b)
return b;
else
return a;
}

struct collocter
{
int val;
int vol;
} bone[1001];
int f[1001];
int main()
{
int t,n,v,i,j;
scanf("%d",&t);
while(t--)
{
memset(f,0,sizeof(f));
scanf("%d%d",&n,&v);
for(i=0; i<n; i++)
scanf("%d",&bone[i].val);
for(i=0; i<n; i++)
scanf("%d",&bone[i].vol);
/**递推过程**/
/**动态转移方程式为f[j]=max(f[j],f[j-bone[i].vol]+bone[i].val)**/
for(i=0; i<n; i++)
for(j=v; j>=0; j--)
if(j>=bone[i].vol)// 这儿想不通为什么递推这样写,递推不是一般都是从前往后推的吗?困惑
f[j]=mymax(f[j],f[j-bone[i].vol]+bone[i].val);
printf("%d\n",f[v]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: