您的位置:首页 > 运维架构

hdu4405 Aeroplane chess

2013-08-20 20:40 225 查看

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 833 Accepted Submission(s): 575


Problem Description

Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.

Input

There are multiple test cases.

Each test case contains several lines.

The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).

Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).

The input end with N=0, M=0.

Output

For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.

Sample Input

2 0
8 3
2 4
4 5
7 8
0 0

Sample Output

1.1667
2.3441

Source

2012 ACM/ICPC Asia Regional Jinhua Online

Recommend

zhoujiaqi2010

很水的概率dp,我们知道,求期望的时候,我们用的从后住前推,其实,我们就可以看成是一个图,是从后向前推的,这一题 就是很明显的要用图了,

我们可以很容易得出状态转移方程dp[i]表示已经走到了i到结束,还要用的步数的期望

如果,一个点,没有和别的点相连,那么这个点可以推出向后的6步,dp[i]=sum{1/6.0dp[i+k]}+1,如果,这个点,是在一个航线上,那么这个点,只能推出,到航线上,别一个点

,那么,这个点的期望 ,不就等于,航线上的另一点个的概率值了么!,这样,我们就可以很快得到解!

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
#define MAXN 100050
int vec[MAXN];
double dp[MAXN];
int main()
{
int n,m,a,b,i,j;
while(scanf("%d%d",&n,&m)!=EOF&&(n+m))
{
memset(vec,-1,sizeof(vec));
memset(dp,0,sizeof(dp));
for(i=0;i<m;i++)
{
scanf("%d%d",&a,&b);
vec[a]=b;
}
dp
=0;
for(i=n-1;i>=0;i--)
{
if(vec[i]!=-1)
dp[i]=dp[vec[i]];
else
{
for(j=1;j<=6;j++)
{
if(i+j<=n)
dp[i]+=1.0/6*dp[i+j];
}
dp[i]+=1.0;
}

}
printf("%.4f\n",dp[0]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: