您的位置:首页 > 其它

poj 1860 Currency Exchange :bellman-ford

2013-08-20 18:18 295 查看
点击打开链接

Currency Exchange

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 16635 Accepted: 5821
Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies.
Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges,
and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively. 

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative
sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description
of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103. 

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102. 

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations
will be less than 104. 

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output
YES

bellman-ford算法,题目大意是有N种货币和M个货币交换点,Nick有一些其中一种货币,每两种货币兑换有一个公式,就是(本金 - 手续费) * 转换率,每个交换点只能交换某两种特定的货币,最后问是否可以通过这些交换点使得最后的本金会增加
bellman-ford计算是否有负圈回路就好,其实就是判断是否有使本金增长的圈

#include<stdio.h>
double map[101][101][2];
double dis[101];
int n, m, s;
double v;
bool bellman()
{
int i, j, k;
for(i = 1; i < 101; i++)
{
dis[i] = 0;
}
dis[s] = v;
for(i = 1; i < n; i++)
{
for(j = 1; j <= n; j++)
{
for(k = 1; k <= n; k++)
{
if(map[j][k][0] > 0)
{
if(dis[k] < (dis[j] - map[j][k][1]) * map[j][k][0])
{
dis[k] = (dis[j] - map[j][k][1]) * map[j][k][0];
}
}
}
}
}
for(j = 1; j <= n; j ++)
{
for(k = 1; k <= n; k++)
{
if(dis[k] < (dis[j] - map[j][k][1]) * map[j][k][0])
return 0;
}
}
return 1;
}
int main()
{

scanf("%d %d %d %lf", &n, &m, &s, &v);
int i = m;
int a, b;
while(i--)
{
scanf("%d %d", &a, &b);
scanf("%lf %lf %lf %lf", &map[a][b][0], &map[a][b][1], &map[b][a][0], &map[b][a][1]);
}
if(bellman() == 0)
printf("YES\n");
else
printf("NO\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: