您的位置:首页 > 其它

hdu_1018_Big Number_201308191556

2013-08-19 17:09 501 查看
Big Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21214 Accepted Submission(s): 9549

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output
The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input
2
10
20

Sample Output
7
19

//Big Number

#include <stdio.h>
#include <math.h>

int main()
{
int N;
scanf("%d",&N);
while(N--)
{
int i,m;
double sum=1;
scanf("%d",&m);
for(i=1;i<=m;i++)
{
sum+=log10(i);
}
printf("%d\n",(int)sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: