您的位置:首页 > 其它

TOJ Right Triangles II

2013-08-19 07:40 471 查看


Right Triangles II 

 

Time Limit(Common/Java):1000MS/3000MS     Memory Limit:65536KByte

Total Submit: 53            Accepted: 14

Description

N points are placed in the coordinate plane.

Write a program that calculates how many ways we can choose three points so that they form a right triangle with legs parallel to the coordinate axes.

A right triangle has one 90-degree internal angle. The legs of a right triangle are its two shorter sides.

Input

The first line of input contains the integer N (3 ≤ N ≤ 100 000), the number of points.

Each of the following N lines contains two integers X and Y (1 ≤ X, Y ≤ 100 000), the coordinates of one point.

No pair of points will share the same pair of coordinates.

Output

Output the number of triangles.

Sample Input

3
4 2
2 1
1 3


Sample Output

0


Uploader

crq

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;

const int maxn = 100008;

vector<__int64> x[maxn];
__int64 y[maxn];

int n;

void work() {
__int64 i, j;
__int64 cnt = 0;
for(i = 1; i < maxn; i++) {//maxn --> n !!!
__int64 Size = x[i].size();
if(Size <= 1) continue;
for(j = 0; j < Size; j++) {
__int64 id = x[i][j];
if(y[id] > 0)
cnt += (Size - 1) * (y[id] - 1);
}
}
printf("%I64d\n", cnt);
}

void init() {
int i;
for(i = 0; i < maxn; i++) {
x[i].clear();
y[i] = 0;
}
}

int main()
{
int i;
int dx, dy;
while(scanf("%d", &n) != EOF) {
init();
for(i = 0; i < n; i++) {
scanf("%d%d", &dx, &dy);
x[dx].push_back(dy);
y[dy]++;
}
work();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: