您的位置:首页 > 其它

Y2K Accounting Bug(poj2586,枚举)

2013-08-18 09:45 323 查看
http://poj.org/problem?id=2586

Y2K Accounting Bug

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 8462 Accepted: 4180

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.

All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237

375 743

200000 849694

2500000 8000000

Sample Output

116

28

300612

Deficit

Source

Waterloo local 2000.01.29

[Submit] [Go Back] [Status] [Discuss]

解析:

给出每月的盈利s,和赤字d,但不知道有多少个月是盈利,多少个月是赤字。

公司在一年内每连续五个月进行一次汇报,总共要进行8次汇报,每次汇报结果的总收入为亏损。

问在这一年内公司是否能挣钱,最多挣多少

思路:

枚举5种可能即可要使得挣钱最多,则赤字的月数越少越好。

以下6种情况:

111111111111(不可能存在)

111101111011

111001110011

110001100011

100001000010

000000000000(必然亏损)

其中0表示赤字,1表示盈利。

则a[5]={0,2,4,6,9,12};

然后计算出每五个月中最少出现赤字月份的个数,带入表中即可、

*/

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
const int maxn=1000+10;
int a[6]={0,2,4,6,9,12};
int main()
{
int s,d,ans;
int i,j;
while(scanf("%d%d",&s,&d)!=EOF)
{
int ok=0;
for(i=4;i>=0;i--)
{if(ok)
break;
for(j=1;j<=5;j++)
if(s*i-j*d<0&&i+j==5)
{
ok=1;
break;
}
}
ans=(12-a[j])*s-a[j]*d;
if(ans>=0)
{printf("%d\n",ans);
}
else
printf("Deficit\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: